This morning, we released version 4.0 of MailChimp for WordPress. While the new version does not come with that many visible changes, it is probably the most important update since we’ve started working on the plugin years ago.

Why update?

Version 4.0 will update you to the latest & greatest MailChimp API, a set of servers the plugin “talks” to for handling all sign-up requests and the likes. MailChimp is completely removing their older API versions at the end of 2016 so it is very important that you are running MailChimp for WordPress version 4.0 or later by then.

Before you update..

Because of changes in the MailChimp API specifications, we were forced to make some changes as well. While we take care of most of these changes automatically, please go through the upgrade guide before updating the plugin to make sure things keep working as expected for you.

The update can be downloaded from the plugin page on WordPress.org or from your WordPress admin area.

If you are not seeing an available update, please deactivate the plugin and then click the “Check Again” button on your updates page.

If you have any questions or concerns about version 4.0, do not hesitate to let us know. We are here to help, as always!